Parabola application down and flow runs failing

Incident Report for Parabola

Resolved

This incident has been stabilized and is resolved.
Posted May 21, 2026 - 21:00 UTC

Monitoring

From 2026-05-21 20:37 - 20:45 UTC, the Parabola application was unavailable and flow runs were failing. During that time, webhook flow triggers were lost. Flows can now be retried. We're continuing to monitor to confirm stability before marking this incident as resolved.

If you're continuing to see issues with your flows, please reach out to support@parabola.io.
Posted May 21, 2026 - 20:52 UTC
This incident affected: Flow Builder and Flow Runs.