App responsiveness issues

Incident Report for Parabola

Resolved

All systems normal
Posted May 15, 2025 - 18:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 17:59 UTC

Investigating

We are investigating issues with delayed responses and slowdowns in one of our systems. The web app and flow runs may be delayed or impacted.
Posted May 15, 2025 - 17:50 UTC
This incident affected: Website, Flow Builder, and Flow Runs.