Microsoft integrations -- results view frozen

Incident Report for Parabola

Resolved

We have resolved the issue with editing and reviewing Microsoft integrations
Posted Sep 17, 2025 - 22:41 UTC

Investigating

We are currently investigating display issues of the Microsoft Sharepoint and OneDrive integrations
Posted Sep 17, 2025 - 21:03 UTC
This incident affected: Flow Runs.