Visualizations slow or failing to load

Incident Report for Parabola

Resolved

This incident, in which visualizations were not loading or taking longer than expected to load, has been resolved. The issue was occurring for some customers from 2026-06-05 through 2026-06-10. We have solved the underlying cause and are following up with more to protect going forward.
Posted Jun 10, 2026 - 22:52 UTC

Identified

The issue with visualizations has been identified and a fix is being developed
Posted Jun 10, 2026 - 17:40 UTC

Investigating

We're currently investigating reports of visualizations not loading, or taking longer than expected to load, within Parabola. The issue appears to be intermittent and does not affect all visualizations or all users.
Posted Jun 10, 2026 - 17:31 UTC
This incident affected: Flow Builder.